Kia Seltos Forum banner

1 - 5 of 5 Posts

·
Registered User
Joined
·
1 Posts
Discussion Starter #1
Hello! I just got my Kia selto about 2 weeks ago. This morning while at a stop light the engine was about to turn off but when I let go of the brake an error cane up saying put car in park and restart. I turned car off and restarted and it was fine but now engine malfunction light is on. Anyone else have this issue ever?
 

·
Registered User
Joined
·
71 Posts
Hello! I just got my Kia selto about 2 weeks ago. This morning while at a stop light the engine was about to turn off but when I let go of the brake an error cane up saying put car in park and restart. I turned car off and restarted and it was fine but now engine malfunction light is on. Anyone else have this issue ever?
Haven't had that error. Perhaps it is related to the AUtoStart feature. I know there were about three system updates when I took my Seltos in for the 6K service so maybe it is related.
 

·
Registered User
2021 Seltos SX Turbo AWD Lunar Orange
Joined
·
3 Posts
Hello! I just got my Kia selto about 2 weeks ago. This morning while at a stop light the engine was about to turn off but when I let go of the brake an error cane up saying put car in park and restart. I turned car off and restarted and it was fine but now engine malfunction light is on. Anyone else have this issue ever?
Likely because the battery is not fully charged. Put a battery charger on battery for 8 hours. This is a common issue with newly delivered vehicles of any make with stop and go feature.
 

·
Registered User
Joined
·
1 Posts
this exact same thing happened to me! So frustrating and kind of scary. The idle engine feature has been super glitchy for me on multiple occasions. And it’s not in extreme situations - just at a normal stop light.

Hello! I just got my Kia selto about 2 weeks ago. This morning while at a stop light the engine was about to turn off but when I let go of the brake an error cane up saying put car in park and restart. I turned car off and restarted and it was fine but now engine malfunction light is on. Anyone else have this issue ever?
 

·
Registered User
2021 Seltos SX Turbo AWD Lunar Orange
Joined
·
3 Posts
As i mentioned earlier in the forum, try charging the battery for 8 hours. Note carefully in the manual how to do that. (take off the positive terminal wire) and hook the negative charger connection to the engine. The autostart feature will not operate if the battery charge is sensed as too low. That is to make sure that you are not stranded. it happens when the car has been stored for more than 3 weeks, such as in dealer lot or if you are not using. The car uses power 24./7 to communicate with the UVO cloud, so the battery goes dead much faster than cars of yester year.
 
1 - 5 of 5 Posts
Top