Kia Seltos Forum banner

1 - 3 of 3 Posts

·
Registered User
Joined
·
48 Posts
Discussion Starter #1 (Edited)
when i come to a stop the switch light turns ON.. and on the gauge cluster the little ISG light comes on in ORANGE. When I take off the light goes out and orange ISG on cluster disappears.

Its 80-95°F here car warms up damn near in the first mile. Even with headlights off and no A/C nothing I do has worked. I drive it in Smart Mode. Idk what the issue is the ONLY modification is I have the BPV bypassed to dump atmosphere and a drop in filter.

180 miles on car it worked for a while
 

Attachments

·
Registered User
Joined
·
69 Posts
when i come to a stop the switch light turns ON.. and on the gauge cluster the little ISG light comes on in ORANGE. When I take off the light goes out and orange ISG on cluster disappears.

Its 80-95°F here car warms up damn near in the first mile. Even with headlights off and no A/C nothing I do has worked. I drive it in Smart Mode. Idk what the issue is the ONLY modification is I have the BPV bypassed to dump atmosphere and a drop in filter.

180 miles on car it worked for a while
I noticed this as well however it only happens when the A/C is on Auto and cooling the car down. Some days it is in the 90s outside and with the A/C at 72 the autostart doesn't kick in. Once the interior has cooled down, the autostart will engage. My friend has a Jeep Cherokee that engages the autostart is always on. It sucks when its hot and the A/C drops at a long light.
 

·
Registered User
Joined
·
48 Posts
Discussion Starter #3
I noticed this as well however it only happens when the A/C is on Auto and cooling the car down. Some days it is in the 90s outside and with the A/C at 72 the autostart doesn't kick in. Once the interior has cooled down, the autostart will engage. My friend has a Jeep Cherokee that engages the autostart is always on. It sucks when its hot and the A/C drops at a long light.
Thats my thoughts. Good call
 
1 - 3 of 3 Posts
Top