Kia Seltos Forum banner
1 - 9 of 9 Posts

· Registered User
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all, I bought my kia seltos 2023 model on November and till now driven over 4000kms. All of sudden yesterday when I started my car and put on address on navigation system . My main console above the drive wheel started to flash. Like it works fine if I'm not using native navigation.

But if I use inbuilt navigation it starts to flash and all the needles in the Speedometer and Fuel Indicators goes to zero. Has anyone faced this issue.

Thank you in advance
 

· Registered User
Joined
·
7 Posts
Hi,

See this thread :
 

· Registered User
Joined
·
3 Posts
Hey all, I bought my kia seltos 2023 model on November and till now driven over 4000kms. All of sudden yesterday when I started my car and put on address on navigation system . My main console above the drive wheel started to flash. Like it works fine if I'm not using native navigation.

But if I use inbuilt navigation it starts to flash and all the needles in the Speedometer and Fuel Indicators goes to zero. Has anyone faced this issue.

Thank you in advance
Yes sir, and posted a tictok. Dealership wasn't able to find anything wrong.

Keep me posted if you hear anything.
 

· Registered User
Seltos GT-line, (=SX), 2020 model, Mars Orange, 1.6L turbo, AWD
Joined
·
224 Posts
Hi,

See this thread :
Someone else posted somewhere about these kinds of intermittent strange electical issues, and found it was all solved by in effect re-booting all the car's computers at once. To do this apparently you just turn everything off. Pop the hood/bonnet, and carefully disconnect the negative (black) battery terminal only, being careful to not touch it against anything metal, then reconnect it after about 30 seconds, and everything comes good. Makes sense to me - bl**dy computers - lov'em and hat'em all 'long same time... :censored:
 

· Registered User
Joined
·
5 Posts
This started happening to me recently - took it to the dealer this morning. I just got the call saying the controller is bad and it will take 7 to 10 days to get that part. I can still drive and use the car as long as I don't use the onboard nav.
 

· Registered User
Seltos GT-line, (=SX), 2020 model, Mars Orange, 1.6L turbo, AWD
Joined
·
224 Posts
This started happening to me recently - took it to the dealer this morning. I just got the call saying the controller is bad and it will take 7 to 10 days to get that part. I can still drive and use the car as long as I don't use the onboard nav.
Have you tried doing the above trick re the complete car computer reboot..? If not, worth trying-can't hurt, in case that's all it is. I doubt the dealer would have thought of that frankly. Could be wrong, but with what you hear dealers telling others with issues...meh..?
 

· Registered User
Joined
·
5 Posts
Have you tried doing the above trick re the complete car computer reboot..? If not, worth trying-can't hurt, in case that's all it is. I doubt the dealer would have thought of that frankly. Could be wrong, but with what you hear dealers telling others with issues...meh..?
No, it's under warranty. They said the the part will be in soon and they will give me a call. IF that doesn't happen then I'll give it a try.
 

· Registered User
Seltos GT-line, (=SX), 2020 model, Mars Orange, 1.6L turbo, AWD
Joined
·
224 Posts
No, it's under warranty. They said the the part will be in soon and they will give me a call. IF that doesn't happen then I'll give it a try.
I'd be doing it anyway. Takes about 1 minute to disconnect the negative terminal, wait 30 seconds, then reconnect. It might do the trick. If not, as you say, it's under warranty, so you are still good.
 
1 - 9 of 9 Posts
Top