Kia Seltos Forum banner
1 - 4 of 4 Posts

·
Registered User
Joined
·
1 Posts
Discussion Starter · #1 ·
Whenever I drive my 2021 Seltos FWD S I plug my phone into the usb to start up android auto to listen to spotify and sometimes use google maps. Lately I've been on some drives and maybe 5 - 20 minutes into the drive my audio will suddenly go back to fm radio and the screen shows that nothing is plugged in. Unplugging the usb cable from the car and from the phone multiple times does nothing to help the car recognize that a device is plugged in, and I've even pulled over and shut the car off and started it back up and that usually doesn't solve the issue either. Interestingly, my phone still shows that it's charging when this happens, but doesn't recognize that it's plugged into a car because nothing comes up about android auto on the phone. I'm going to start using a different USB cable, but the fact that the phone continues charging when this happens makes me doubt it's a faulty cable.

Later the same day or the next day everything will work as normal again when I start up the car. After a bit of driving the issue repeats itself some days, and others works just fine.

Anyone had this issue? It's extremely frustrating as I frequently have to drive to new places for work, so when android auto stops working while I am using google maps then I'm dealing with awkwardly setting up navigation on my phone in my lap instead of having it on my HUD.

I'm due for 15k miles service soon and plan on asking the dealer to look at this, but I have a feeling they're just going to say they couldn't recreate the problem and shrug. Back in the summer with about 10k miles I had my car stall out twice over the course of a few weeks when i took my foot off the brake and the auto engine shutoff went to start the car back up, and the dealer just said they couldn't recreate the problem and not to worry about it unless it keeps happening. (It hasn't happened again)
 

·
Registered User
2022 Kia Seltos LX AWD (On order)
Joined
·
12 Posts
My Samsung (Android) uses the same cords as my last phone (Nokia). About 2 years ago, I ordered a set of 4 cords of varying length from Amazon to keep in the car and around the house. I think I paid around $12 for the set.

A few months ago, the one in the car started cutting in/out while using Android Auto. I thought it might be the car ('20 Soul), but the problem went away when I brought out one of my seldom-used cables. Apparently, the cables have a finite lifespan (just like us!). Try switching cables and see if that helps. Good luck.
 
  • Like
Reactions: Feefer

·
Registered User
Joined
·
1 Posts
Yes same thing happens to me (Seltos AWD S '21) almost every time I drive. Although mine automatically reconnects itself, it is quite annoying. I've tried different cables and nothing seemed to resolve the issue. Let us know what the dealer says.

Whenever I drive my 2021 Seltos FWD S I plug my phone into the usb to start up android auto to listen to spotify and sometimes use google maps. Lately I've been on some drives and maybe 5 - 20 minutes into the drive my audio will suddenly go back to fm radio and the screen shows that nothing is plugged in. Unplugging the usb cable from the car and from the phone multiple times does nothing to help the car recognize that a device is plugged in, and I've even pulled over and shut the car off and started it back up and that usually doesn't solve the issue either. Interestingly, my phone still shows that it's charging when this happens, but doesn't recognize that it's plugged into a car because nothing comes up about android auto on the phone. I'm going to start using a different USB cable, but the fact that the phone continues charging when this happens makes me doubt it's a faulty cable.

Later the same day or the next day everything will work as normal again when I start up the car. After a bit of driving the issue repeats itself some days, and others works just fine.

Anyone had this issue? It's extremely frustrating as I frequently have to drive to new places for work, so when android auto stops working while I am using google maps then I'm dealing with awkwardly setting up navigation on my phone in my lap instead of having it on my HUD.

I'm due for 15k miles service soon and plan on asking the dealer to look at this, but I have a feeling they're just going to say they couldn't recreate the problem and shrug. Back in the summer with about 10k miles I had my car stall out twice over the course of a few weeks when i took my foot off the brake and the auto engine shutoff went to start the car back up, and the dealer just said they couldn't recreate the problem and not to worry about it unless it keeps happening. (It hasn't happened again)
 

·
Registered User
Joined
·
5 Posts
I keep a GPS in my 2021 Seltos S. Some places my phone does not get good reception so the map function does not work.
 
1 - 4 of 4 Posts
Top