Kia Seltos Forum banner
1 - 11 of 11 Posts

·
Registered User
Joined
·
1 Posts
Discussion Starter · #1 ·
Bought my Seltos SP2 GT Line AWD 12 months ago, and have 20K on the clock. Went to go this morning and it will not reverse and the "Check engine" warning light came on. It is now being towed in to be diagnosed. Just wondering if anyone else has had this issue. I'm in Australia, thanks :)
 

·
Registered User
Joined
·
3 Posts
Bought my Seltos SP2 GT Line AWD 12 months ago, and have 20K on the clock. Went to go this morning and it will not reverse and the "Check engine" warning light came on. It is now being towed in to be diagnosed. Just wondering if anyone else has had this issue. I'm in Australia, thanks :)
I am facing this now..
Today morning it happened and 1 day back only i had my servicing. Even my km clocked 20k.
 

·
Registered User
Joined
·
1 Posts
Bought my Seltos SP2 GT Line AWD 12 months ago, and have 20K on the clock. Went to go this morning and it will not reverse and the "Check engine" warning light came on. It is now being towed in to be diagnosed. Just wondering if anyone else has had this issue. I'm in Australia, thanks :)
Bought my Seltos SP2 GT Line AWD 12 months ago, and have 20K on the clock. Went to go this morning and it will not reverse and the "Check engine" warning light came on. It is now being towed in to be diagnosed. Just wondering if anyone else has had this issue. I'm in Australia, thanks :)
This just happened to me as well :-( in process of getting it diagnosed. What was the outcome of your situation if you may?
 

·
Registered User
Joined
·
1 Posts
Bought my Seltos SP2 GT Line AWD 12 months ago, and have 20K on the clock. Went to go this morning and it will not reverse and the "Check engine" warning light came on. It is now being towed in to be diagnosed. Just wondering if anyone else has had this issue. I'm in Australia, thanks :)

Same Seltos GT Line AWD and same years/model/Kms, last Friday 1/10/2021, car would not go past first gear and could not enter in reverse. I had to two the Seltos to Kia Blacktown and now they still can't give me an answer.
 

·
Registered User
Joined
·
3 Posts
Same Seltos GT Line AWD and same years/model/Kms, last Friday 1/10/2021, car would not go past first gear and could not enter in reverse. I had to two the Seltos to Kia Blacktown and now they still can't give me an answer.
Mostly it will be again Clutch Actuator. ( seems they have global issue in this part)
 

·
Registered User
Joined
·
2 Posts
Bought my Seltos SP2 GT Line AWD 12 months ago, and have 20K on the clock. Went to go this morning and it will not reverse and the "Check engine" warning light came on. It is now being towed in to be diagnosed. Just wondering if anyone else has had this issue. I'm in Australia, thanks :)
This JUST happened to me. They said that they have to replace the transmission and I am so angry.
 

·
Registered User
Joined
·
5 Posts
Bought my Seltos SP2 GT Line AWD 12 months ago, and have 20K on the clock. Went to go this morning and it will not reverse and the "Check engine" warning light came on. It is now being towed in to be diagnosed. Just wondering if anyone else has had this issue. I'm in Australia, thanks :)
I am in US. I had the similar problem as yours. My car was revving in D gear when I was driving in a local street and I slowed down and pulled over to the shoulder of the street. And I noticed a reverse gear wasn't working as I tried to park correctly. So I drove it to the dealership in lower speed and it has been 7 weeks since i dropped the car. The dealer said mine has an issue with transmission module. But the part is in backorder. I had used a few of rental cars since I didn't know how long it would get it fixed but this week the dealership finally offered me a loaner car.
My car is turbo SX, has 10,000 miles, i've had it for 17 months. Too much stress and time consuming from this issue.
 

·
Registered User
Joined
·
2 Posts
I am in US. I had the similar problem as yours. My car was revving in D gear when I was driving in a local street and I slowed down and pulled over to the shoulder of the street. And I noticed a reverse gear wasn't working as I tried to park correctly. So I drove it to the dealership in lower speed and it has been 7 weeks since i dropped the car. The dealer said mine has an issue with transmission module. But the part is in backorder. I had used a few of rental cars since I didn't know how long it would get it fixed but this week the dealership finally offered me a loaner car.
My car is turbo SX, has 10,000 miles, i've had it for 17 months. Too much stress and time consuming from this issue.
I was having the same problem with the engine revving. Too, it in and of course they couldn’t duplicate the problem so I. Their minds”there is no problem”
Had them check it again when I brought it in for the piston problem recall and they reset the ‘learn mode’.
Seems to be better now.
But now I have a problem with the clock resetting itself!! They say it’s a problem with the navigation head unit! They’ll fix it under warranty (it’s a 2021 bought in Oct., 2020 with just today hitting the 10K mile mark.
 
1 - 11 of 11 Posts
Top