Kia Seltos Forum banner

1 - 7 of 7 Posts

·
Registered User
Joined
·
3 Posts
Discussion Starter #1
Just wondering if this is a known issue as I got in the car this morning and my touchscreen is blank. The radio was working, but the touchscreen was not responsive. Tried restarting car, but alas, still dead. Thanks for feedback.
 

·
Registered User
Joined
·
77 Posts
Hmm. Yeah I would stop into the service center if it stays off. If you’re shutting down just to try and see if it changes, make sure you lock the vehicle using the key fob.

Keep us posted


Sent from my iPhone using Tapatalk
 

·
Registered User
Joined
·
3 Posts
Discussion Starter #5
Hmm. Yeah I would stop into the service center if it stays off. If you’re shutting down just to try and see if it changes, make sure you lock the vehicle using the key fob.

Keep us posted


Sent from my iPhone using Tapatalk
I just tried it and it now works. The locking of the vehicle fixed it! Thank you. :) Is this something that is a known issue?
 

·
Registered User
Joined
·
77 Posts
I haven't personally seen the issue - but I'm sure that if it happened to you, you're not the only one. Locking the car just ensures that everything is fully switched off from power. For now at least, this thread can be found in search if other people have a similar experience.
 

·
Registered User
Joined
·
105 Posts
Just wondering if this is a known issue as I got in the car this morning and my touchscreen is blank. The radio was working, but the touchscreen was not responsive. Tried restarting car, but alas, still dead. Thanks for feedback.
SO, I had something similar happen. Tends to occur most often when my phone locks in Drive Mode while I am plugging in the USB. I've found that pressing the media button will cause the media selection screen to come on. Usually CarPlay is selected but I just tap it again and CarPlay pops up in the 2/3 side of the screen.
 
1 - 7 of 7 Posts
Top