Kia Seltos Forum banner
1 - 10 of 10 Posts

·
Registered User
Joined
·
1 Posts
Discussion Starter · #1 ·
Good day all

Were new , just bought out 2022 Kia Silos , ex premium.

Upon our first road trip to break in the car, little over 350 km, and 5 hr drive through mountains and town , we discovered a weird problem, even the deal says they have not seen . while driving , the entire dash , lights, tack ,Speedo, everything goes blank, tack and rpm needles drop to zero, then flashes back on with a systems check . all this happens while driving , predominantly in corners or good bump in road. So Monday we drop off car, and are awaiting an answer . ( Dealer did give us a loaner car so were in good hands )

This happen to anyone else , and what was the fix ?
 

·
Registered User
Joined
·
61 Posts
This has happened to me twice now (that I have caught, as I’m not always looking at the dash). Both times on the highway, everything else is not impacted. But the dash does a complete shut down (everything off, needles down) and then boots back up again. Dealership can’t find an error code or anything.
2021 Seltos SX Canada.
 

·
Registered User
2021 KIA Seltos SX Turbo
Joined
·
182 Posts
Good day all

Were new , just bought out 2022 Kia Silos , ex premium.

Upon our first road trip to break in the car, little over 350 km, and 5 hr drive through mountains and town , we discovered a weird problem, even the deal says they have not seen . while driving , the entire dash , lights, tack ,Speedo, everything goes blank, tack and rpm needles drop to zero, then flashes back on with a systems check . all this happens while driving , predominantly in corners or good bump in road. So Monday we drop off car, and are awaiting an answer . ( Dealer did give us a loaner car so were in good hands )

This happen to anyone else , and what was the fix ?
Something similar, see my past post. I kept getting Lane Assist on the slightest turn to the right. Then finally I got all the warning lights came on. Drove back to dealership and they told me it was a grounding issue with one of the sensors. I would tell the dealership to check all sensors if they are properly grounded. I would ask.
 

·
Registered User
Joined
·
2 Posts
I had same issue with my 2022 Seltos SX. System check kept running and all lights flash on/off. Speedo/tacho flatlined. Discovered it was linked to the system navigation. When I cancel the route everything goes to normal. When I enter a destination and start guidance the issue comes back. I tried resetting the system but it didn't work. But at least I can get rid of the problem by not using maps (until I get it fixed).
 

·
Registered User
2021 KIA Seltos SX Turbo
Joined
·
182 Posts
Good day all

Were new , just bought out 2022 Kia Silos , ex premium.

Upon our first road trip to break in the car, little over 350 km, and 5 hr drive through mountains and town , we discovered a weird problem, even the deal says they have not seen . while driving , the entire dash , lights, tack ,Speedo, everything goes blank, tack and rpm needles drop to zero, then flashes back on with a systems check . all this happens while driving , predominantly in corners or good bump in road. So Monday we drop off car, and are awaiting an answer . ( Dealer did give us a loaner car so were in good hands )

This happen to anyone else , and what was the fix ?
Just to add what I stated previously. Did you have something that was plugged into the OBD socket, dash cam, analyzer etc.? I have a dashcam that's using the OBD and my console went dark. I was told to unplug the OBD and restart the car. This worked. I haven't had any issues since.
 

·
Registered User
2021 KIA Seltos SX Turbo
Joined
·
182 Posts
Good day all

Were new , just bought out 2022 Kia Silos , ex premium.

Upon our first road trip to break in the car, little over 350 km, and 5 hr drive through mountains and town , we discovered a weird problem, even the deal says they have not seen . while driving , the entire dash , lights, tack ,Speedo, everything goes blank, tack and rpm needles drop to zero, then flashes back on with a systems check . all this happens while driving , predominantly in corners or good bump in road. So Monday we drop off car, and are awaiting an answer . ( Dealer did give us a loaner car so were in good hands )

This happen to anyone else , and what was the fix ?
read my previous post. I had a similar problem 2 years ago.
(Seltos Electronic Stability Control)
2 months after getting the car, I was driving on back roads, It started to vibrate when I slightly turn my car to the right. The Stability control kept coming on with the slightest turn to the right. Then my display went blank. minute later all my warning lights came on. Problem was that a sensor wasn't grounded properly. They had to take the ground wire off and sand down the terminal to get a better contact. It's been fine ever since.
 

·
Registered User
Joined
·
1 Posts
Good day all

Were new , just bought out 2022 Kia Silos , ex premium.

Upon our first road trip to break in the car, little over 350 km, and 5 hr drive through mountains and town , we discovered a weird problem, even the deal says they have not seen . while driving , the entire dash , lights, tack ,Speedo, everything goes blank, tack and rpm needles drop to zero, then flashes back on with a systems check . all this happens while driving , predominantly in corners or good bump in road. So Monday we drop off car, and are awaiting an answer . ( Dealer did give us a loaner car so were in good hands )

This happen to anyone else , and what was the fix ?
yep same things is happening to mine right now. It’s in the service centre and they just called and are keeping for another day
 

·
Registered User
Joined
·
2 Posts
I had same issue with my 2022 Seltos SX. System check kept running and all lights flash on/off. Speedo/tacho flatlined. Discovered it was linked to the system navigation. When I cancel the route everything goes to normal. When I enter a destination and start guidance the issue comes back. I tried resetting the system but it didn't work. But at least I can get rid of the problem by not using maps (until I get it fixed).
Were you able to get this fixed and if so what was the solution?
 
1 - 10 of 10 Posts
Top